Support Portal

for ProcessRobot and WinAutomation

Start a new topic

SSL/TLS error when using invoke web service action


We are having issues when invoking web service. When sending a request, we get an error form WinAutomation "Runtime Error: Failed to invoke web service: The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.". When trying to access API via web browser there is a message notifying that "The site is not secure". Now we do know that we are working with a trustworthy API. Is there any way to work around the issue and bypass the error?

Thank you in advance!

1 person has this question


Hello Zygintas,

Please check if you are able to invoke the web service with another 3rd party tool (SOAPUI for example) and let us know about the result.

In this way, we will be able to find out if it is an issue with the configuration or with WinAutomation.

In general, each web service comes with an API documentation which should be instructed in order to find out the correct parameters to use in the Invoke Action.

I am getting the same error. I have successfully accessed the web service using RESTED on Firefox; however, cannot get it to work on ProcessRobot Invoke Web Service. Here are the error messages:

Runtime Error: Failed to invoke web service: The request was aborted: Could not create SSL/TLS secure channel.

The request was aborted: Could not create SSL/TLS secure channel.

System.Net.WebException: The request was aborted: Could not create SSL/TLS secure channel.
   at System.Net.HttpWebRequest.GetResponse()
   at WinAutomation.Actions.Runtime.WebActions.InvokeWebService(Variant url, Variant userAgent, Variant filePath, Variant destinationFolder, Variant userName, Variant varPassword, Variant customHeaders, Variant requestBody, Variant& responseHeaders, Variant& webPageText, Variant& downloadedFile, Variant& statusCode, Boolean useSsl, Boolean followRedirection, Boolean clearCookies, Int32 connectionTimeout, String method, String accept, String contentType, Boolean saveFileToDisk, Boolean keepOriginalFileName, Boolean useCredentials, Boolean passwordDirectly, String password, String userSpecifiedEncodingName, Boolean encodeBodyBeforeInvoke, Boolean failOnErrorStatus)

Thought I'd provide the solution I found. The web service we were using required TLS 1.2 Our Windows machine did not have that enabled by default. Once we enabled it, everything worked smoothly. Here's the link to the steps I used to enable it:

It's actually another Softomotive support page; however, it wasn't clear that answer solves this error message. Hopefully it is now.

Login or Signup to post a comment