Support Portal

for ProcessRobot and WinAutomation

Start a new topic

Writing Number value in Excel

Is there any way to write numeric value to Excel as a number, not text?

I've tried nearly all possible ways but no luck -- either I get number as text or fraction part get lost.

In results attached all cell have General format.

(4.3 KB)
(158 KB)

Hi Roman,

You could write the value using the following syntax:


And the result:

Hi Konstantinos, 

As you can see in my initial message, I need not text value like one in your example, but a number value in Excel without any post-updates like 'copy - paste as value at paste-add 0'.

In the attachment you can find more detailed results with additional test cases.

Still haven't found the right way.

(14.1 KB)
(289 KB)

Hello Roman, this issue maybe is related with your locale settings.

For a quick test, could you set on the control panel the decimal separator as dot and the thousands separator as comma and send the number again?

This is happening to me for a long time and I never worried too much, no idea about how to solve it.

I asume you have set your system decimal separator as comma, isn't it?

just trying a bit.

screenshot attached.

not very nice solution, but give it a try on your side. Maybe WinAutomation people can take a look to this.

The regional settings is most likely what is causing the inconsistency with the representation of the values in the excel file.  Roberto's proposal is simple and should work. 

You could format the column as number before updating the cells either using UI/Window actions to automate the procedure as you would manually, or you could use the "Run VBScript" action to manipulate the excel file accordingly.

I've tried Roberto's proposal, still no luck.

Thought, writing number to Excel should be simple operation, not via UI actions or vbs. 

I had the same (or similar) issue, just with decimals - integers were populated as numbers, decimals as text. I used Replace function in SQL command to replace "," comma with dot "." and the decimals were correctly populated as numbers. (And presented with comma as decimal separator in Excel because of local settings)

1 person likes this
Login or Signup to post a comment