Support Portal

for ProcessRobot and WinAutomation

Start a new topic

Unable to send cURL cmd via Write to CMD Session

Hey,


Strange one, I am unable to send a cURL command using the built in CMD Session. I can send other commands just fine, even other cURL commands, all except this one. This is the command I am trying to send:

 

curl -b headers.txt -b cookies.txt --data “query=\"search+term\"&resultTypeSelect=blogs&languagesSelect=all&frequency=daily&volume=all&email=myemailhere123@hotmail.com" https://alerts.talkwalker.com/alerts/new

Is there anything here that WinAutomation doesn't like or needs to be escaped. I have tried sending it from a notepad and saved as a variable, but any attempt just returns nothing. The %Cmdoutput% just shows the command with nothing returned, even though it shows the command as it should be.


I can send this through windows cmd prompt just fine and it returns a success. I am stumped!


1 person has this question

ADMIN

Hello Jack, 


Have you tried to add a "Wait" or a "Wait for Text on Cmd session" action before you read from Cmd?

Yeah, I have tried both, I have set 'Wait for text on Cmd' to 'true'. but it just hangs there and never finds it. Wait time to 10 seconds after it sends, still nothing. When I check my %CMDoutput% it just shows the argument and no output at all, like it hasn't even executed it (it should show 'success:true'.) As I say, the exact command works manually, even copying and pasting it from WinAutomation to cmd line works but it doesn't work through WinAutomation. Also, I am not totally new with this, I have several cURL commands set up for other tasks, via WA but my only guess it that this has some special character that WA is struggling with and maybe needs to be escaped. Like I say, I'm at a loss here.

not sure if this is a forum issue, but there is some diference with “ and "


maybe you can set all the parameter string to a variable to monitor, or just simplify the curl expression to guess where is failing.

Login or Signup to post a comment