Sometimes, when you open the WA Console, you are prompted to register your License key. This is normal for the first time you open the WA Console, but it may also occur in the future for a number of reasons.


The License is usually prompted to be registered again in the following scenarios:
  1. The "C:\ProgramData\Softomotive\WinAutomation\GlobalSettings.dat" is missing. This file contains the License Key encrypted. If the file is missing, it will be auto generated when WA Server boots. The License Key is retrieved when WA Server starts, so if the file was missing, you will be prompted to register it again.
  2. The machine ID changed. When WA Server will retrieve the License Key from the above file, it will check if it matches the correct machine ID that was generated. The machine ID is also stored in that file, so if your machine ID changed, it will behave as it is now in a different machine. The machine ID is being generated using the UUID of the machine and the SerialNumber of the OS.
  3. You had unassigned the License Key remotely from your WA User Area. When WA Server will retrieve the License Key from the above file, it will check for it's validity through the WA Licensing server as well, and it will remove it from there since you had unassigned it remotely.


In order to understand the case better, you need to monitor and see which scenario applies and then find out the cause:
  • Open Windows Powershell and Run the following commands and see if these number change every time you login again:

    (Get-WmiObject Win32_ComputerSystemProduct).UUID
    (Get-WmiObject Win32_OperatingSystem).SerialNumber


  • Monitor the GlobalSettings.dat file, see if for any reason it does not save your changes when you log out and it is reset or deleted.